summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2022-06-26 16:33:30 -0400
committerPaul Smith <psmith@gnu.org>2022-07-09 10:46:47 -0400
commit0cbee1b475710a247c20d772699f10cf9d2badc9 (patch)
treee0fe4e5c703b14291d1cb95f1327f4a424ebd7bf /configure.ac
parentd63925d8637db8acd4f2e62f8cbc9f70a07501d8 (diff)
downloadmake-git-0cbee1b475710a247c20d772699f10cf9d2badc9.tar.gz
bootstrap: Remove strtoll()
This pulls in entirely too much stuff we don't need. Instead grab just the gnulib source file, then include it in src/misc.c. * bootstrap.conf: Add just the lib/strtol.c source file. * configure.ac: Check for strtoll. * src/misc.c: Include strtol.c, with QUAD set, if needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index da6d6a5f..bb2eb331 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,8 +133,8 @@ AS_IF([test "$ac_cv_func_gettimeofday" = yes],
[Define to 1 if you have a standard gettimeofday function])
])
-AC_CHECK_FUNCS([strdup strndup memrchr mempcpy umask mkstemp mktemp fdopen \
- dup dup2 getcwd realpath sigsetmask sigaction \
+AC_CHECK_FUNCS([strtoll strdup strndup memrchr mempcpy umask mkstemp mktemp \
+ fdopen dup dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
getrlimit setrlimit setvbuf pipe strsignal \
lstat readlink atexit isatty ttyname pselect posix_spawn \