summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2020-04-24 18:37:39 -0700
committerdormando <dormando@rydia.net>2020-04-30 17:34:17 -0700
commit4f2753909324c3532836926de647c301a1407f05 (patch)
treea9d0b07a23026cc3e6a7aa547bc44c49108dcc48 /configure.ac
parent97e8ebd82fc7ac142a30bd0740cd60bc37b8c8bc (diff)
downloadmemcached-4f2753909324c3532836926de647c301a1407f05.tar.gz
Disable aarch64 hw crc32 function for now
Also re-adds the start time detection of intel instruction. I never got a proper test platform for the ARM bits and it's been stuck as a configure flag. I'd be happy to add it back if that situation changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b192e60..ffc98b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,8 +82,10 @@ fi
AM_PROG_CC_C_O
AC_PROG_INSTALL
-AC_ARG_ENABLE(arm_crc32,
- [AS_HELP_STRING([--enable-arm-crc32], [Enable ARMv8 CRC32 instructions])])
+dnl ARM crc32 optimization is disabled until we have hardware for an automated
+dnl regression test.
+dnl AC_ARG_ENABLE(arm_crc32,
+dnl [AS_HELP_STRING([--enable-arm-crc32], [Enable ARMv8 CRC32 instructions])])
AC_ARG_ENABLE(extstore,
[AS_HELP_STRING([--disable-extstore], [Disable external storage (extstore)])])