summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2019-09-17 20:06:09 -0700
committerdormando <dormando@rydia.net>2019-09-17 20:08:44 -0700
commit9485db55edf2dc6b75b2024770ae41ad6b68de18 (patch)
tree85fe3eef417a6d24d0419eea9d8549ce43e60388 /configure.ac
parentb5ea90160579ba060b8e1d269595b3ec5d77d740 (diff)
downloadmemcached-9485db55edf2dc6b75b2024770ae41ad6b68de18.tar.gz
restart: fixes for 32bit and chunked items.1.5.18
severe bug in item chunk fixup (wasn't doing it at all!) failed to check on my 32bit builders... and 32bit platforms weren't working at all. This is a bit of a kludge since I'm still working around having ptrdiff, but it seems to work. also fixes a bug with missing null byte for meta filename.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d960a5..fb78fc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,6 +268,20 @@ return sizeof(void*) == 8 ? 0 : 1;
])
fi
+dnl If data pointer is 64bit or not.
+AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([], [dnl
+return sizeof(void*) == 8 ? 0 : 1;
+ ])
+],[
+ have_64bit_ptr=yes
+],[
+])
+
+if test $have_64bit_ptr = yes; then
+ AC_DEFINE(HAVE_64BIT_PTR, 1, [data pointer is 64bit])
+fi
+
# Issue 213: Search for clock_gettime to help people linking
# with a static version of libevent
AC_SEARCH_LIBS(clock_gettime, rt)