summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d960a5..fb78fc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,6 +268,20 @@ return sizeof(void*) == 8 ? 0 : 1;
])
fi
+dnl If data pointer is 64bit or not.
+AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([], [dnl
+return sizeof(void*) == 8 ? 0 : 1;
+ ])
+],[
+ have_64bit_ptr=yes
+],[
+])
+
+if test $have_64bit_ptr = yes; then
+ AC_DEFINE(HAVE_64BIT_PTR, 1, [data pointer is 64bit])
+fi
+
# Issue 213: Search for clock_gettime to help people linking
# with a static version of libevent
AC_SEARCH_LIBS(clock_gettime, rt)