summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 41b3974..5560da3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,12 +85,9 @@ AC_ARG_ENABLE([logging],
)
AC_ARG_ENABLE([valgrind-tests],
[AC_HELP_STRING([--enable-valgrind-tests],
- [run checks through valgrind for static library (default = no)])],
+ [run checks through valgrind (default = no)])],
[case $enableval in
- yes) AS_IF([test "x$enable_shared" != "xno"],
- [AC_MSG_ERROR([Valgrind checks do not work with shared libraries; use --enable-valgrind-tests only with --disable-shared])],
- [gl_VALGRIND_TESTS]
- ) ;;
+ yes) gl_VALGRIND_TESTS ;;
no) ;;
*) AC_MSG_ERROR([Bad value for --enable-valgrind-tests: Use yes or no]) ;;
esac