summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-09-08 17:29:52 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-09-08 17:29:52 +0000
commitb371c9c089eefac7c0293fce522550e832dfaea9 (patch)
treec52ae254deb8e376eac6ee40a2efd1b35d0657ab /configure.ac
parent78103685e978e892ae0a00322d9d43b82616c1ec (diff)
downloadmpc-b371c9c089eefac7c0293fce522550e832dfaea9.tar.gz
configure.ac: corrected broken detection of CC and CFLAGS from gmp.h
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@1091 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4f8829a..02ad6c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,11 @@ AC_ARG_ENABLE([valgrind-tests],
]
)
+# Check for user specification of CC or CFLAGS
+if test -n "$CFLAGS" || test -n "$CC" ; then
+ user_redefine_cc_or_cflags=yes
+fi
+
# Setup CC and CFLAGS
AC_PROG_CC
AC_LANG(C)
@@ -100,11 +105,6 @@ AC_LANG(C)
# Set up LibTool
AC_PROG_LIBTOOL
-# Check for user specification of CC or CFLAGS
-if test -n "$CFLAGS" || test -n "$CC" ; then
- user_redefine_cc=yes
-fi
-
# Check GMP Header
AC_MSG_CHECKING(for gmp.h)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
@@ -115,7 +115,7 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
])
# Check for GMP CFLAGS in gmp.h
-if test -z "$user_redefine_cc" ; then
+if test -z "$user_redefine_cc_or_cflags" ; then
MPC_GMP_CC_CFLAGS
fi