summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4f8829a..02ad6c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,11 @@ AC_ARG_ENABLE([valgrind-tests],
]
)
+# Check for user specification of CC or CFLAGS
+if test -n "$CFLAGS" || test -n "$CC" ; then
+ user_redefine_cc_or_cflags=yes
+fi
+
# Setup CC and CFLAGS
AC_PROG_CC
AC_LANG(C)
@@ -100,11 +105,6 @@ AC_LANG(C)
# Set up LibTool
AC_PROG_LIBTOOL
-# Check for user specification of CC or CFLAGS
-if test -n "$CFLAGS" || test -n "$CC" ; then
- user_redefine_cc=yes
-fi
-
# Check GMP Header
AC_MSG_CHECKING(for gmp.h)
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
@@ -115,7 +115,7 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
])
# Check for GMP CFLAGS in gmp.h
-if test -z "$user_redefine_cc" ; then
+if test -z "$user_redefine_cc_or_cflags" ; then
MPC_GMP_CC_CFLAGS
fi