summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2012-05-14 15:56:24 +0000
committerzimmerma <zimmerma@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2012-05-14 15:56:24 +0000
commite5fdbfe19de286f70dd8729e63caa07356e6add4 (patch)
tree6858d89c5d80ddf6f6b3cf89598c5cb9c5ab0959 /configure.ac
parent145e0b4f94b544f55d48d8f5d4718478a44c78ce (diff)
downloadmpc-e5fdbfe19de286f70dd8729e63caa07356e6add4.tar.gz
[configure.ac] only add warning flags to CFLAGS when the user did not define it
(see http://lists.gforge.inria.fr/pipermail/mpc-discuss/2012-May/001115.html) git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@1157 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6e5d127..4e2b35b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,12 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
])
# Check if compiler accepts warning flags and add them to CFLAGS
-MPC_C_CHECK_WARNINGCFLAGS
+# Note: don't do this if the user defined CFLAGS, since adding new flags
+# might override the user's settings, see
+# http://lists.gforge.inria.fr/pipermail/mpc-discuss/2012-May/001115.html
+if test -z "$CFLAGS"; then
+ MPC_C_CHECK_WARNINGCFLAGS
+fi
# Checks for header files.