summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6e5d127..4e2b35b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,12 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
])
# Check if compiler accepts warning flags and add them to CFLAGS
-MPC_C_CHECK_WARNINGCFLAGS
+# Note: don't do this if the user defined CFLAGS, since adding new flags
+# might override the user's settings, see
+# http://lists.gforge.inria.fr/pipermail/mpc-discuss/2012-May/001115.html
+if test -z "$CFLAGS"; then
+ MPC_C_CHECK_WARNINGCFLAGS
+fi
# Checks for header files.