summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-01-18 12:48:30 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-01-18 12:48:30 +0000
commit79b8a4aa8bab2c1c63cfd20416367120762db85c (patch)
treeb0011cf9405288ca613005f83bcd068183e8f1ac /tests/Makefile.am
parent3237c68dfc83a83a1271755ed0cda374aebe0069 (diff)
downloadmpc-79b8a4aa8bab2c1c63cfd20416367120762db85c.tar.gz
sin_cos: bug fix to allow overlap in argument and result
previously, there was a problem when computing sin and cos (none of rop_sin and rop_cos being NULL), the arguments were non-finite, purely real or purely imaginary, and op was equal to one of the output values tests: added generic and reuse tests for functions with one input and two outputs, labelled by "cc_c"; in particular, new test file tsin_cos.c git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@882 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cac6756..6c6a39f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,12 +7,12 @@ LDADD = libmpc-tests.la $(top_builddir)/src/libmpc.la
# "make foo".
LOADLIBES=$(DEFS) -I$(top_srcdir)/src -I$(top_builddir) $(CPPFLAGS) $(CFLAGS) $(top_builddir)/tests/.libs/libmpc-tests.a $(top_builddir)/src/.libs/libmpc.a $(LIBS)
-check_PROGRAMS = tabs tacos tacosh tadd tadd_fr tadd_si tadd_ui targ tasin tasinh \
-tatan tatanh tconj tcos tcosh tdiv tdiv_2exp tdiv_fr tdiv_ui texp tfma \
+check_PROGRAMS = tabs tacos tacosh tadd tadd_fr tadd_si tadd_ui targ tasin \
+tasinh tatan tatanh tconj tcos tcosh tdiv tdiv_2exp tdiv_fr tdiv_ui texp tfma \
tfr_div tfr_sub timag tio_str tlog tmul tmul_2exp tmul_fr tmul_i tmul_si \
tmul_ui tneg tnorm tpow tpow_ld tpow_d tpow_fr tpow_si tpow_ui tpow_z tprec \
-tproj treal treimref tset tsin tsinh tsqr tsqrt tstrtoc tsub tsub_fr tsub_ui \
-ttan ttanh tui_div tui_ui_sub tget_version
+tproj treal treimref tset tsin tsin_cos tsinh tsqr tsqrt tstrtoc tsub tsub_fr \
+tsub_ui ttan ttanh tui_div tui_ui_sub tget_version
check_LTLIBRARIES=libmpc-tests.la
libmpc_tests_la_SOURCES=mpc-tests.h random.c tgeneric.c read_data.c \