summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 02ad6c7..a93d766 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,9 +93,9 @@ AC_ARG_ENABLE([valgrind-tests],
]
)
-# Check for user specification of CC or CFLAGS
-if test -n "$CFLAGS" || test -n "$CC" ; then
- user_redefine_cc_or_cflags=yes
+# Check for CC and CFLAGS in gmp.h unless the user specified one of them
+if test -z $CC -a -z $CFLAGS; then
+ MPC_GMP_CC_CFLAGS
fi
# Setup CC and CFLAGS
@@ -114,11 +114,6 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
AC_MSG_ERROR([gmp.h cannot be found or is unusable.])
])
-# Check for GMP CFLAGS in gmp.h
-if test -z "$user_redefine_cc_or_cflags" ; then
- MPC_GMP_CC_CFLAGS
-fi
-
# Check if compiler accepts warning flags and add them to CFLAGS
MPC_C_CHECK_WARNINGCFLAGS