summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-09-09 17:01:34 +0000
committerenge <enge@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2011-09-09 17:01:34 +0000
commitb62f0dd739664eb944b0342ef8d3242fc096a608 (patch)
tree95982100318e95fa9a1824a098f75844167cbae2 /configure.ac
parentb371c9c089eefac7c0293fce522550e832dfaea9 (diff)
downloadmpc-b62f0dd739664eb944b0342ef8d3242fc096a608.tar.gz
configure.ac, mpc.m4: copied check for CC and CFLAGS in gmp.h from mpfr
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@1092 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 02ad6c7..a93d766 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,9 +93,9 @@ AC_ARG_ENABLE([valgrind-tests],
]
)
-# Check for user specification of CC or CFLAGS
-if test -n "$CFLAGS" || test -n "$CC" ; then
- user_redefine_cc_or_cflags=yes
+# Check for CC and CFLAGS in gmp.h unless the user specified one of them
+if test -z $CC -a -z $CFLAGS; then
+ MPC_GMP_CC_CFLAGS
fi
# Setup CC and CFLAGS
@@ -114,11 +114,6 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
AC_MSG_ERROR([gmp.h cannot be found or is unusable.])
])
-# Check for GMP CFLAGS in gmp.h
-if test -z "$user_redefine_cc_or_cflags" ; then
- MPC_GMP_CC_CFLAGS
-fi
-
# Check if compiler accepts warning flags and add them to CFLAGS
MPC_C_CHECK_WARNINGCFLAGS