summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-09-29 22:57:48 +0000
committersleske <sleske@ffa7fe5e-494d-0410-b361-a75ebd5db220>2013-09-29 22:57:48 +0000
commitf7f4439130bad36c698c2441563f4945c6117f5e (patch)
tree2fd64fb042348d9184baff724efd0ae23b7bbf4f /CMakeLists.txt
parentd94f702e75e7f212a5f8a880febfb530d6a618b2 (diff)
downloadnavit-svn-f7f4439130bad36c698c2441563f4945c6117f5e.tar.gz
Fix:build/cmake:Handle "support/gettext_intl" like the other support libs.
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@5649 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2159275..7b7223d6 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,7 @@ add_plugin(support/glib "native Glib found" FALSE)
add_plugin(support/zlib "native zlib found" FALSE)
add_plugin(support/libpng "native libpng found" FALSE)
add_plugin(support/wordexp "native wordexp found" FALSE)
+add_plugin(support/gettext_intl "native libintl found" FALSE)
add_module(font/freetype "freetype not found" FALSE)
add_module(graphics/android "FreeType library not found" FALSE)
add_module(graphics/gd "FreeType library not found" FALSE)
@@ -174,7 +175,7 @@ CHECK_FUNCTION_EXISTS(fsync HAVE_FSYNC)
### Configure build
#Required libraries, supplied with navit
if (NOT HAVE_LIBINTL)
- add_plugin(support/gettext_intl "native libintl missing" TRUE)
+ set_with_reason(support/gettext_intl "native libintl missing" TRUE)
set(USE_LIBGNUINTL TRUE)
else()
CHECK_LIBRARY_EXISTS(intl libintl_fprintf "" NEEDS_LIBINTL)
@@ -184,7 +185,6 @@ else()
endif(NEEDS_LIBINTL)
endif(NOT HAVE_LIBINTL)
-
if (CMAKE_USE_PTHREADS_INIT)
if (NOT ANDROID)
list(APPEND NAVIT_LIBS pthread)