summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-26 07:50:41 -0700
committerAllen Martin <amartin@nvidia.com>2012-06-26 18:04:53 -0700
commitf60b9d2aee60f48ca358a0cedf266580b8c4659e (patch)
treefb611c0638514d97a3b3dc54250bc91e010349ba /configure.ac
parent37eb31de9a5e55006f4bdaf4bbc9926b999692a7 (diff)
downloadtegrarcm-f60b9d2aee60f48ca358a0cedf266580b8c4659e.tar.gz
use pkg-config for libusb-1.0 look up
More friendly to exotic libusb setups. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Change-Id: I36f54f2a6e36773c8cf213c56deea053b1f81083 Reviewed-on: http://git-master/r/111408 Reviewed-by: Allen Martin <amartin@nvidia.com> Tested-by: Allen Martin <amartin@nvidia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6aebd33..0736a80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,16 +10,14 @@ AC_CONFIG_HEADERS([config.h])
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC
+PKG_PROG_PKG_CONFIG
# Checks for libraries.
AC_CHECK_LIB([pthread],
[pthread_create],
[HAVE_PTHREAD=1],
[AC_MSG_ERROR([libpthread is not installed.])])
-AC_CHECK_LIB([usb-1.0],
- [libusb_init],
- [HAVE_USB=1],
- [AC_MSG_ERROR([libusb-1.0 is not installed.])])
+PKG_CHECK_MODULES([LIBUSB], [libusb-1.0])
AC_LANG(C++)
SAVED_LDFLAGS=$LDFLAGS
LDFLAGS="$LDFLAGS -lcryptopp"