summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6aebd33..0736a80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,16 +10,14 @@ AC_CONFIG_HEADERS([config.h])
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC
+PKG_PROG_PKG_CONFIG
# Checks for libraries.
AC_CHECK_LIB([pthread],
[pthread_create],
[HAVE_PTHREAD=1],
[AC_MSG_ERROR([libpthread is not installed.])])
-AC_CHECK_LIB([usb-1.0],
- [libusb_init],
- [HAVE_USB=1],
- [AC_MSG_ERROR([libusb-1.0 is not installed.])])
+PKG_CHECK_MODULES([LIBUSB], [libusb-1.0])
AC_LANG(C++)
SAVED_LDFLAGS=$LDFLAGS
LDFLAGS="$LDFLAGS -lcryptopp"