summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-06 04:52:38 +0000
committerDarren Tucker <dtucker@dtucker.net>2022-11-06 18:51:52 +1100
commit12af712d116f42164bcfa56db901d06e4fa27199 (patch)
tree5e8e0b1162c5c9d679660719583aeb5b942ac239 /configure.ac
parent40b0a5eb6e3edfa2886b60c09c7803353b0cc7f5 (diff)
downloadopenssh-git-12af712d116f42164bcfa56db901d06e4fa27199.tar.gz
configure.ac: Fix -Wstrict-prototypes
Clang 16 now warns on this and it'll be removed in C23, so let's just be future proof. It also reduces noise when doing general Clang 16 porting work (which is a big job as it is). github PR#355. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1866aea5..4bf758ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -713,7 +713,7 @@ case "$host" in
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <mach-o/dyld.h>
#include <stdlib.h>
-int main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
+int main(void) { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
exit(0);
else
exit(1);
@@ -1658,7 +1658,7 @@ AC_ARG_WITH(ldns,
# include <stdint.h>
#endif
#include <ldns/ldns.h>
-int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); }
+int main(void) { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); }
]])
],
[AC_MSG_RESULT(yes)],
@@ -4262,7 +4262,7 @@ dnl test snprintf (broken on SCO w/gcc)
#include <stdlib.h>
#include <string.h>
#ifdef HAVE_SNPRINTF
-int main()
+int main(void)
{
char buf[50];
char expected_out[50];
@@ -4279,7 +4279,7 @@ int main()
exit(0);
}
#else
-int main() { exit(0); }
+int main(void) { exit(0); }
#endif
]])], [ true ], [ AC_DEFINE([BROKEN_SNPRINTF]) ],
AC_MSG_WARN([cross compiling: Assuming working snprintf()])