summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2023-01-07 14:30:43 +1100
committerDarren Tucker <dtucker@dtucker.net>2023-01-07 14:30:43 +1100
commit26cab41c05d7b0859d2a1ea5b6ed253d91848a80 (patch)
treef1e2dc7854229258043c4a421d3160315336c057 /configure.ac
parent5532e010a0eeb6aa264396514f9aed7948471538 (diff)
downloadopenssh-git-26cab41c05d7b0859d2a1ea5b6ed253d91848a80.tar.gz
Use autoconf to find openssl binary.
It's possible to install an OpenSSL in a path not in the system's default library search path. OpenSSH can still use this (eg if you specify an rpath) but the openssl binary there may not work. If one is available on the system path just use that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f6802500..6e1de3c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2683,6 +2683,7 @@ AC_CHECK_FUNCS([getpgrp],[
# Search for OpenSSL
saved_CPPFLAGS="$CPPFLAGS"
saved_LDFLAGS="$LDFLAGS"
+openssl_bin_PATH="$PATH"
AC_ARG_WITH([ssl-dir],
[ --with-ssl-dir=PATH Specify path to OpenSSL installation ],
[
@@ -2712,14 +2713,11 @@ AC_ARG_WITH([ssl-dir],
else
CPPFLAGS="-I${withval} ${CPPFLAGS}"
fi
- if test -x "${withval}/bin/openssl"; then
- openssl_bin="${withval}/bin/openssl"
- elif test -x "${withval}/apps/openssl"; then
- openssl_bin="${withval}/apps/openssl"
- fi
+ openssl_bin_PATH="${PATH}${PATH_SEPARATOR}${withval}/bin${PATH_SEPARATOR}${withval}/apps"
fi
]
)
+AC_PATH_PROGS([openssl_bin], openssl, [], [$openssl_bin_PATH])
AC_SUBST(OPENSSL_BIN, [${openssl_bin}])
AC_ARG_WITH([openssl-header-check],