summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2023-03-24 15:21:18 +1100
committerDamien Miller <djm@mindrot.org>2023-03-24 15:26:26 +1100
commitb7e27cfd7f163fc16b4c5d041cc28ee488a5eeec (patch)
tree33b1a0bba44ceae877a9eaad4e445143952be8f3 /configure.ac
parent7280401bdd77ca54be6867a154cc01e0d72612e0 (diff)
downloadopenssh-git-b7e27cfd7f163fc16b4c5d041cc28ee488a5eeec.tar.gz
put back SSLeay_version compat in configure test
Needed to detect old versions and give good "your version is bad" messages at configure time; spotted by dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c0ccdf1..07893e87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2803,7 +2803,16 @@ if test "x$openssl" = "xyes" ; then
#define DATA "conftest.ssllibver"
]], [[
FILE *f;
-
+ /* We need these legacy bits to warn for old libcrypto */
+ #ifndef OPENSSL_VERSION
+ # define OPENSSL_VERSION SSLEAY_VERSION
+ #endif
+ #ifndef HAVE_OPENSSL_VERSION
+ # define OpenSSL_version SSLeay_version
+ #endif
+ #ifndef HAVE_OPENSSL_VERSION_NUM
+ # define OpenSSL_version_num SSLeay
+ #endif
if ((f = fopen(DATA, "w")) == NULL)
exit(1);
if (fprintf(f, "%08lx (%s)",