summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c0ccdf1..07893e87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2803,7 +2803,16 @@ if test "x$openssl" = "xyes" ; then
#define DATA "conftest.ssllibver"
]], [[
FILE *f;
-
+ /* We need these legacy bits to warn for old libcrypto */
+ #ifndef OPENSSL_VERSION
+ # define OPENSSL_VERSION SSLEAY_VERSION
+ #endif
+ #ifndef HAVE_OPENSSL_VERSION
+ # define OpenSSL_version SSLeay_version
+ #endif
+ #ifndef HAVE_OPENSSL_VERSION_NUM
+ # define OpenSSL_version_num SSLeay
+ #endif
if ((f = fopen(DATA, "w")) == NULL)
exit(1);
if (fprintf(f, "%08lx (%s)",