summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-03-28 06:34:53 +0100
committerMonty Taylor <mordred@inaugust.com>2013-03-28 06:40:13 +0100
commit0206c2d5dd37c3ce1440b5083574979129f12e77 (patch)
treed59aafd58c48a6d43d5821667af4626794e3356c /setup.py
parent23ee4b818d800d08abf123a65c69213c0eff0900 (diff)
downloadpython-novaclient-0206c2d5dd37c3ce1440b5083574979129f12e77.tar.gz
Update to latest openstack.common.setup.
We actually don't need the silly versioninfo file at all anymore. Change-Id: Ic759c39a29b07d41a96849db84a7f9990ec8a3eb
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index f5343cc0..1e4c1cfb 100644
--- a/setup.py
+++ b/setup.py
@@ -21,14 +21,14 @@ from novaclient.openstack.common import setup
def read_file(file_name):
return open(os.path.join(os.path.dirname(__file__), file_name)).read()
-
+project = 'python-novaclient'
setuptools.setup(
- name="python-novaclient",
- version=setup.get_post_version('novaclient'),
- author="Rackspace, based on work by Jacob Kaplan-Moss",
- author_email="github@racklabs.com",
- description="Client library for OpenStack Nova API.",
+ name=project,
+ version=setup.get_version(project),
+ author='OpenStack',
+ author_email='openstack-dev@lists.openstack.org',
+ description="Client library for OpenStack Compute API.",
long_description=read_file("README.rst"),
license="Apache License, Version 2.0",
url="https://github.com/openstack/python-novaclient",