summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAidan Shribman <aidan.shribman@gmail.com>2021-04-02 19:08:19 +0000
committerBen Pfaff <blp@ovn.org>2021-04-08 08:57:37 -0700
commit23f9ec9eb057597f4afab78651d1202f74da381e (patch)
tree21561caa651a6fda6fd1ec83c42e9979037df599 /Makefile.am
parent332b8a3e4ec0cd5f4aa9e6c1cf3a2aefb0c40b2e (diff)
downloadopenvswitch-23f9ec9eb057597f4afab78651d1202f74da381e.tar.gz
make: don't prompt during build
When running repeated builds using `make build` you get prompts in cases the `mv` command is about to overwrite a file which is write-protect. This patch forced the `mv` w/o prompting for approval. Signed-off-by: Aidan Shribman <aidan.shribman@gmail.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 691a005ad..cb8076433 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,7 +168,7 @@ SUFFIXES += .in
@if head -n 1 $@.tmp | grep '#!' > /dev/null; then \
chmod +x $@.tmp; \
fi
- $(AM_V_at) mv $@.tmp $@
+ $(AM_V_at) mv -f $@.tmp $@
SUFFIXES += .xml
%: %.xml