summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYi-Hung Wei <yihung.wei@gmail.com>2017-02-17 17:47:45 -0800
committerJoe Stringer <joe@ovn.org>2017-02-21 11:36:40 -0800
commitc458e4a372d1dc5e85885480bf482c3522a57922 (patch)
treedcd3e80f9ca21196c624a1c002992a34546db3c2 /Makefile.am
parentaafee638217b24eb165e052866a9be4e3f695ce9 (diff)
downloadopenvswitch-c458e4a372d1dc5e85885480bf482c3522a57922.tar.gz
Makefile.am: Avoid include/ depending on lib/.
Add a build check that public openvswitch header file should not include internal library. Suggested-by: Joe Stringer <joe@ovn.org> Suggested-by: Daniele Di Proietto <diproiettod@vmware.com> Signed-off-by: Yi-Hung Wei <yihung.wei@gmail.com> Signed-off-by: Joe Stringer <joe@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b1b48d64..7ff66fe15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -230,6 +230,13 @@ config-h-check:
echo "every C source file must #include <config.h>."; \
exit 1; \
fi
+ if grep '#include' $(srcdir)/include/openvswitch/*.h | \
+ grep -vE '(<.*>)|("openvswitch)|("openflow)'; \
+ then \
+ echo "See above for list of violations of the rule that"; \
+ echo "public openvswitch header file should not include internal library."; \
+ exit 1; \
+ fi
.PHONY: config-h-check
# Check for printf() type modifiers that MSVC doesn't support.