summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b1b48d64..7ff66fe15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -230,6 +230,13 @@ config-h-check:
echo "every C source file must #include <config.h>."; \
exit 1; \
fi
+ if grep '#include' $(srcdir)/include/openvswitch/*.h | \
+ grep -vE '(<.*>)|("openvswitch)|("openflow)'; \
+ then \
+ echo "See above for list of violations of the rule that"; \
+ echo "public openvswitch header file should not include internal library."; \
+ exit 1; \
+ fi
.PHONY: config-h-check
# Check for printf() type modifiers that MSVC doesn't support.