summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTJ Kolev <tjkolev@gmail.com>2023-02-04 20:27:39 -0600
committerTJ Kolev <tjkolev@gmail.com>2023-02-04 20:27:39 -0600
commit5fc636979d25d26612f0453916a13b232af574cf (patch)
tree80b4df3862a53ce958de7209c177281fc171f38f
parent5da2360dc606816c4491f321b20e2cf5b1efa13c (diff)
downloaddropbear-5fc636979d25d26612f0453916a13b232af574cf.tar.gz
Fuzzy Fixing
Was able to reproduce the pipeline's fuzzing build error: ``` ./src/options.h:20:10: fatal error: 'default_options_guard.h' file not found ``` The fix for my local environment was to rearange the order of dependencies. Then default_options_guard.h get generated before it's needed. tjk :)
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 632c9c4..401ea40 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -309,7 +309,7 @@ fuzzstandalone: fuzz/fuzz-harness.o fuzz-targets
# provides a main in fuzz-harness.c
fuzz-targets: $(FUZZ_TARGETS) $(FUZZER_OPTIONS)
-$(FUZZ_TARGETS): $(FUZZ_OBJS) $(allobjs) $(LIBTOM_DEPS)
+$(FUZZ_TARGETS): $(LIBTOM_DEPS) $(allobjs) $(FUZZ_OBJS)
$(CXX) $(CXXFLAGS) fuzz/$@.o $(LDFLAGS) $(allobjs) -o $@$(EXEEXT) $(LIBTOM_LIBS) $(LIBS) $(FUZZLIB) @CRYPTLIB@
# fuzzers that use the custom mutator - these expect a SSH network stream