summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorrofl0r <retnyg@gmx.net>2018-06-17 11:22:38 +0100
committerrofl0r <retnyg@gmx.net>2018-06-17 11:22:38 +0100
commit38c2aea709b47e2e3c08ecebe0c51a3a4f528635 (patch)
tree3b8830f0b2b28d8142427c4c49caa6be5ded02de /Makefile
parentedf21ef7aa9423b95aa49e2018eacfbcf1f3eac9 (diff)
downloadlibnl-tiny-38c2aea709b47e2e3c08ecebe0c51a3a4f528635.tar.gz
fix install command for retarded OS's (Mac OS X)
install.sh taken from https://github.com/rofl0r/install.sh
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 0e1a11b..b663cc0 100644
--- a/Makefile
+++ b/Makefile
@@ -5,6 +5,7 @@ includedir=$(prefix)/include
CC=gcc
AR=ar
RANLIB=ranlib
+INSTALL=./install.sh
WFLAGS=-Wall
CFLAGS?=-O2
INCLUDES=-Iinclude
@@ -50,13 +51,13 @@ $(PCFILE): $(PCFILE).in
$(DESTDIR)$(includedir)/libnl-tiny/%: include/%
- install -D -m 644 $< $@
+ $(INSTALL) -D -m 644 $< $@
$(DESTDIR)$(libdir)/%: %
- install -D -m 644 $< $@
+ $(INSTALL) -D -m 644 $< $@
$(DESTDIR)$(libdir)/pkgconfig/%: %
- install -D -m 644 $< $@
+ $(INSTALL) -D -m 644 $< $@
.PHONY: all clean install