summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-02-11 22:10:03 +0100
committerFelix Fietkau <nbd@openwrt.org>2013-02-11 22:10:03 +0100
commit35d767f41931df99533fccd0fbf3aa844d869139 (patch)
treef02280ffd44c7a08070aa1335a78688c5681db4b /CMakeLists.txt
parentcf90523881521fe8396a728230169b6b8ea7e8da (diff)
downloadnetifd-35d767f41931df99533fccd0fbf3aa844d869139.tar.gz
prefer to link against libjson-c over libjson (the new library name in git versions of json-c)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74cb080..2076fc9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,8 +18,9 @@ SET(SOURCES
ubus.c)
+find_library(json NAMES json-c json)
SET(LIBS
- ubox ubus uci json blobmsg_json)
+ ubox ubus uci ${json} blobmsg_json)
IF (NOT DEFINED LIBNL_LIBS)
SET(LIBNL_LIBS -lnl)