summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74cb080..2076fc9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,8 +18,9 @@ SET(SOURCES
ubus.c)
+find_library(json NAMES json-c json)
SET(LIBS
- ubox ubus uci json blobmsg_json)
+ ubox ubus uci ${json} blobmsg_json)
IF (NOT DEFINED LIBNL_LIBS)
SET(LIBNL_LIBS -lnl)