summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-02 18:41:36 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-10-02 18:41:36 +0200
commitaab5615166efb78d793eccd1a5d5ac7aab6324f5 (patch)
tree7e533ca7835b6e2f4c4f6361799a8427778c40c9 /CMakeLists.txt
parent216f718323126aa5b89b820363c20f49488cbba1 (diff)
downloadnetifd-aab5615166efb78d793eccd1a5d5ac7aab6324f5.tar.gz
add a variable to allow forcing dummy mode on linux systems
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fb8ae1..5b847ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ SET(SOURCES
SET(LIBS
ubox ubus uci json blobmsg_json)
-IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
SET(SOURCES ${SOURCES} system-linux.c)
SET(LIBS ${LIBS} nl)
ELSE()