summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-06 16:54:16 +0200
committerFelix Fietkau <nbd@openwrt.org>2012-09-06 16:54:38 +0200
commitb077337e6f213975a66e89d61b702aae48314885 (patch)
treed034677624bbef60d0a82c9cff823fde93bf5424 /CMakeLists.txt
parent3b5a5c3e99a4ceb1428d58aecc38d5adf9438541 (diff)
downloadnetifd-b077337e6f213975a66e89d61b702aae48314885.tar.gz
add optional flag for disabling compiler optimization (debug only)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ef4dfa..74cb080 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,9 @@ ENDIF()
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)
+ IF(NO_OPTIMIZE)
+ ADD_DEFINITIONS(-O0)
+ ENDIF()
ENDIF()