summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2013-03-03 18:20:10 +0100
committerFelix Fietkau <nbd@openwrt.org>2013-03-04 18:41:49 +0100
commitb8688d2960c998b60713deeff7df1603f7a8bd3e (patch)
treeab56bb441f494c0427d662a54b367853b24bca25 /CMakeLists.txt
parent486aa750a164d41905beb61afec89268e3eb7f48 (diff)
downloadnetifd-b8688d2960c998b60713deeff7df1603f7a8bd3e.tar.gz
fix libnl detection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2076fc9..f7e9a04 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,8 @@ SET(LIBS
ubox ubus uci ${json} blobmsg_json)
IF (NOT DEFINED LIBNL_LIBS)
- SET(LIBNL_LIBS -lnl)
+ FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+ SET(LIBNL_LIBS ${libnl})
ENDIF()
IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)