summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-09 18:57:42 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-10-09 18:57:42 +0200
commitbe8f32edac81aa4d5c24c1cfa109c23c48827997 (patch)
tree9c9129880fc7edd7cfe5e920a700ac694d4f806c /CMakeLists.txt
parent5c8785ac0d0d7943de370ae4eefd87f56bb65ba9 (diff)
downloadnetifd-be8f32edac81aa4d5c24c1cfa109c23c48827997.tar.gz
add a variable for overriding the libnl linker command
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 461c07c..a6e228a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,9 +19,13 @@ SET(SOURCES
SET(LIBS
ubox ubus uci json blobmsg_json)
+IF (NOT DEFINED LIBNL_LIBS)
+ SET(LIBNL_LIBS -lnl)
+ENDIF()
+
IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
SET(SOURCES ${SOURCES} system-linux.c)
- SET(LIBS ${LIBS} nl)
+ SET(LIBS ${LIBS} ${LIBNL_LIBS})
ELSE()
ADD_DEFINITIONS(-DDUMMY_MODE=1)
SET(SOURCES ${SOURCES} system-dummy.c)