summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-04-08 09:12:50 +0200
committerSteven Barth <steven@midlink.org>2013-04-08 09:12:50 +0200
commit3fb3c327d889a8c5e0370259c4c6360c7d3106cb (patch)
treecfc6e794c4cea9ff8ecbf0d0432b440123e84a3d /CMakeLists.txt
parent4369d2f0e1ab9682d677f2f8fd876329e740fb0b (diff)
downloadodhcp6c-3fb3c327d889a8c5e0370259c4c6360c7d3106cb.tar.gz
Fix compilation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db7ef65..b1871a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ cmake_policy(SET CMP0015 NEW)
project(odhcp6c C)
set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -std=c99")
-add_definitions(-D_GNU_SOURCE -Wall -Werror -Wextra -pedantic)
+add_definitions(-D_GNU_SOURCE -Os -Wall -Werror -Wextra -pedantic)
add_executable(odhcp6c src/odhcp6c.c src/dhcpv6.c src/ra.c src/script.c src/md5.c)
target_link_libraries(odhcp6c resolv)