summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadopenwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
-rw-r--r--config/Config-kernel.in1
-rw-r--r--package/kernel/linux/modules/crypto.mk4
-rw-r--r--package/kernel/linux/modules/fs.mk10
-rw-r--r--package/kernel/linux/modules/input.mk17
-rw-r--r--package/kernel/linux/modules/leds.mk1
-rw-r--r--package/kernel/linux/modules/netdevices.mk7
-rw-r--r--package/kernel/linux/modules/netsupport.mk3
-rw-r--r--package/kernel/linux/modules/other.mk7
-rw-r--r--package/kernel/linux/modules/usb.mk4
-rw-r--r--package/kernel/linux/modules/video.mk2
-rw-r--r--target/linux/bcm27xx/modules/other.mk2
-rw-r--r--target/linux/bcm27xx/modules/sound.mk3
-rw-r--r--target/linux/pistachio/image/Makefile6
-rw-r--r--target/linux/x86/modules.mk2
14 files changed, 19 insertions, 50 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 979a44660d..3a2189d63a 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -1107,7 +1107,6 @@ config KERNEL_PAGE_POOL
config KERNEL_PAGE_POOL_STATS
bool "Page pool stats support"
depends on KERNEL_PAGE_POOL
- depends on !LINUX_5_10
#
# NFS related symbols
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 446801ae23..a3785d26fd 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -824,9 +824,7 @@ $(eval $(call KernelPackage,crypto-rmd160))
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
- DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac \
- +LINUX_5_10:kmod-crypto-sha256 \
- +LINUX_5_15:kmod-crypto-sha512
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha512
KCONFIG:= \
CONFIG_CRYPTO_DRBG \
CONFIG_CRYPTO_DRBG_HMAC=y \
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 547cc79644..77d8d6c98b 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -98,20 +98,18 @@ define KernelPackage/fs-cifs
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +LINUX_5_10:kmod-crypto-md4\
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \
+kmod-crypto-cmac \
+kmod-crypto-hmac \
- +LINUX_5_10:kmod-crypto-arc4 \
+kmod-crypto-aead \
+kmod-crypto-ccm \
+kmod-crypto-ecb \
+kmod-crypto-des \
- +(LINUX_5_15):kmod-asn1-decoder \
- +(LINUX_5_15):kmod-oid-registry \
- +(LINUX_5_15):kmod-dnsresolver
+ +kmod-asn1-decoder \
+ +kmod-oid-registry \
+ +kmod-dnsresolver
endef
define KernelPackage/fs-cifs/description
@@ -367,7 +365,6 @@ $(eval $(call KernelPackage,fs-msdos))
define KernelPackage/fs-netfs
SUBMENU:=$(FS_MENU)
TITLE:=Network Filesystems support
- DEPENDS:=@LINUX_5_15
KCONFIG:= CONFIG_NETFS_SUPPORT
FILES:=$(LINUX_DIR)/fs/netfs/netfs.ko
AUTOLOAD:=$(call AutoLoad,28,netfs)
@@ -531,7 +528,6 @@ define KernelPackage/fs-ntfs3
KCONFIG:= CONFIG_NTFS3_FS CONFIG_NTFS3_FS_POSIX_ACL=y
FILES:=$(LINUX_DIR)/fs/ntfs3/ntfs3.ko
$(call AddDepends/nls)
- DEPENDS+=@!LINUX_5_10
AUTOLOAD:=$(call AutoLoad,80,ntfs3)
endef
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 6cc72207f3..92587b1874 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -92,7 +92,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
define KernelPackage/input-gpio-keys-polled
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Polled GPIO key support
- DEPENDS:=@GPIO_SUPPORT +kmod-input-core +LINUX_5_10:kmod-input-polldev
+ DEPENDS:=@GPIO_SUPPORT +kmod-input-core
KCONFIG:= \
CONFIG_KEYBOARD_GPIO_POLLED \
CONFIG_INPUT_KEYBOARD=y
@@ -142,21 +142,6 @@ endef
$(eval $(call KernelPackage,input-joydev))
-define KernelPackage/input-polldev
- SUBMENU:=$(INPUT_MODULES_MENU)
- TITLE:=Polled Input device support
- DEPENDS:=+kmod-input-core @LINUX_5_10
- KCONFIG:=CONFIG_INPUT_POLLDEV
- FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-endef
-
-define KernelPackage/input-polldev/description
- Kernel module for support of polled input devices
-endef
-
-$(eval $(call KernelPackage,input-polldev))
-
-
define KernelPackage/input-matrixkmap
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Input matrix devices support
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index ce72465ce4..fcf9c987e8 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -118,7 +118,6 @@ $(eval $(call KernelPackage,ledtrig-pattern))
define KernelPackage/ledtrig-tty
SUBMENU:=$(LEDS_MENU)
TITLE:=LED Trigger for TTY devices
- DEPENDS:=@LINUX_5_15
KCONFIG:=CONFIG_LEDS_TRIGGER_TTY
FILES:=$(LED_TRIGGER_DIR)/ledtrig-tty.ko
AUTOLOAD:=$(call AutoLoad,50,ledtrig-tty)
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index ade6438b9c..dd458ece4c 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1448,7 +1448,6 @@ $(eval $(call KernelPackage,sfc-falcon))
define KernelPackage/wwan
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=WWAN Driver Core
- DEPENDS:=@LINUX_5_15
KCONFIG:=CONFIG_WWAN
FILES:=$(LINUX_DIR)/drivers/net/wwan/wwan.ko
AUTOLOAD:=$(call AutoProbe,wwan)
@@ -1464,7 +1463,7 @@ $(eval $(call KernelPackage,wwan))
define KernelPackage/mhi-net
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=MHI Network Device
- DEPENDS:=@LINUX_5_15 @PCI_SUPPORT +kmod-mhi-bus
+ DEPENDS:=@PCI_SUPPORT +kmod-mhi-bus
KCONFIG:=CONFIG_MHI_NET
FILES:=$(LINUX_DIR)/drivers/net/mhi_net.ko
AUTOLOAD:=$(call AutoProbe,mhi_net)
@@ -1479,7 +1478,7 @@ $(eval $(call KernelPackage,mhi-net))
define KernelPackage/mhi-wwan-ctrl
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=MHI WWAN Control
- DEPENDS:=@LINUX_5_15 @PCI_SUPPORT +kmod-mhi-bus +kmod-wwan
+ DEPENDS:=@PCI_SUPPORT +kmod-mhi-bus +kmod-wwan
KCONFIG:=CONFIG_MHI_WWAN_CTRL
FILES:=$(LINUX_DIR)/drivers/net/wwan/mhi_wwan_ctrl.ko
AUTOLOAD:=$(call AutoProbe,mhi_wwan_ctrl)
@@ -1495,7 +1494,7 @@ $(eval $(call KernelPackage,mhi-wwan-ctrl))
define KernelPackage/mhi-wwan-mbim
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=MHI MBIM
- DEPENDS:=@LINUX_5_15 @PCI_SUPPORT +kmod-mhi-bus +kmod-wwan
+ DEPENDS:=@PCI_SUPPORT +kmod-mhi-bus +kmod-wwan
KCONFIG:=CONFIG_MHI_WWAN_MBIM
FILES:=$(LINUX_DIR)/drivers/net/wwan/mhi_wwan_mbim.ko
AUTOLOAD:=$(call AutoProbe,mhi_wwan_mbim)
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index d9d6a98ed2..4653b82565 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1187,7 +1187,7 @@ define KernelPackage/sctp
FILES:= $(LINUX_DIR)/net/sctp/sctp.ko
AUTOLOAD:= $(call AutoLoad,32,sctp)
DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac \
- +LINUX_5_15:kmod-udptunnel4 +LINUX_5_15:kmod-udptunnel6
+ +kmod-udptunnel4 +kmod-udptunnel6
endef
define KernelPackage/sctp/description
@@ -1443,7 +1443,6 @@ define KernelPackage/qrtr
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Qualcomm IPC Router support
HIDDEN:=1
- DEPENDS:=@!LINUX_5_10
KCONFIG:=CONFIG_QRTR
FILES:= \
$(LINUX_DIR)/net/qrtr/qrtr.ko
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index e8b4ea54fe..51e70fbe18 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1251,8 +1251,8 @@ $(eval $(call KernelPackage,keys-trusted))
define KernelPackage/tpm
SUBMENU:=$(OTHER_MENU)
TITLE:=TPM Hardware Support
- DEPENDS:= +kmod-random-core +(LINUX_5_15):kmod-asn1-decoder \
- +(LINUX_5_15):kmod-asn1-encoder +(LINUX_5_15):kmod-oid-registry
+ DEPENDS:= +kmod-random-core +kmod-asn1-decoder \
+ +kmod-asn1-encoder +kmod-oid-registry
KCONFIG:= CONFIG_TCG_TPM
FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
AUTOLOAD:=$(call AutoLoad,10,tpm,1)
@@ -1336,7 +1336,6 @@ $(eval $(call KernelPackage,i6300esb-wdt))
define KernelPackage/mhi-bus
SUBMENU:=$(OTHER_MENU)
TITLE:=MHI bus
- DEPENDS:=@LINUX_5_15
KCONFIG:=CONFIG_MHI_BUS \
CONFIG_MHI_BUS_DEBUG=y
FILES:=$(LINUX_DIR)/drivers/bus/mhi/core/mhi.ko
@@ -1352,7 +1351,7 @@ $(eval $(call KernelPackage,mhi-bus))
define KernelPackage/mhi-pci-generic
SUBMENU:=$(OTHER_MENU)
TITLE:=MHI PCI controller driver
- DEPENDS:=@LINUX_5_15 @PCI_SUPPORT +kmod-mhi-bus
+ DEPENDS:=@PCI_SUPPORT +kmod-mhi-bus
KCONFIG:=CONFIG_MHI_BUS_PCI_GENERIC
FILES:=$(LINUX_DIR)/drivers/bus/mhi/mhi_pci_generic.ko
AUTOLOAD:=$(call AutoProbe,mhi_pci_generic)
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 5747ad2166..2561f36aa3 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1155,7 +1155,7 @@ $(eval $(call KernelPackage,usb-net-aqc111))
define KernelPackage/usb-net-asix
TITLE:=Kernel module for USB-to-Ethernet Asix convertors
- DEPENDS:=+kmod-libphy +LINUX_5_15:kmod-net-selftests +LINUX_5_15:kmod-mdio-devres +kmod-phy-ax88796b
+ DEPENDS:=+kmod-libphy +kmod-net-selftests +kmod-mdio-devres +kmod-phy-ax88796b
KCONFIG:=CONFIG_USB_NET_AX8817X
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/asix.ko
AUTOLOAD:=$(call AutoProbe,asix)
@@ -1394,7 +1394,7 @@ define KernelPackage/usb-net-rtl8152
KCONFIG:=CONFIG_USB_RTL8152
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/r8152.ko
AUTOLOAD:=$(call AutoProbe,r8152)
- $(call AddDepends/usb-net, +LINUX_5_10:kmod-crypto-hash)
+ $(call AddDepends/usb-net)
endef
define KernelPackage/usb-net-rtl8152/description
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index a89ceef54b..f1e61f33a5 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -226,7 +226,7 @@ define KernelPackage/drm
TITLE:=Direct Rendering Manager (DRM) support
HIDDEN:=1
DEPENDS:=+kmod-dma-buf +kmod-i2c-core +PACKAGE_kmod-backlight:kmod-backlight \
- +(LINUX_5_15):kmod-fb
+ +kmod-fb
KCONFIG:=CONFIG_DRM
FILES:= \
$(LINUX_DIR)/drivers/gpu/drm/drm.ko \
diff --git a/target/linux/bcm27xx/modules/other.mk b/target/linux/bcm27xx/modules/other.mk
index a9103029ed..99b71d4d69 100644
--- a/target/linux/bcm27xx/modules/other.mk
+++ b/target/linux/bcm27xx/modules/other.mk
@@ -10,7 +10,7 @@ define KernelPackage/pwm-raspberrypi-poe
CONFIG_PWM_RASPBERRYPI_POE
FILES:=$(LINUX_DIR)/drivers/pwm/pwm-raspberrypi-poe.ko
AUTOLOAD:=$(call AutoLoad,20,pwm-raspberrypi-poe)
- DEPENDS:=@TARGET_bcm27xx @LINUX_5_15 +kmod-hwmon-pwmfan
+ DEPENDS:=@TARGET_bcm27xx +kmod-hwmon-pwmfan
endef
define KernelPackage/pwm-raspberrypi-poe/description
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index 182d80a2c8..47c0a93879 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -371,8 +371,7 @@ define KernelPackage/sound-soc-chipdip-dac
$(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
DEPENDS:= \
- kmod-sound-soc-bcm2835-i2s \
- @LINUX_5_10
+ kmod-sound-soc-bcm2835-i2s
$(call AddDepends/sound)
endef
diff --git a/target/linux/pistachio/image/Makefile b/target/linux/pistachio/image/Makefile
index 9c0e9da91f..64898b46e0 100644
--- a/target/linux/pistachio/image/Makefile
+++ b/target/linux/pistachio/image/Makefile
@@ -5,11 +5,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-ifdef CONFIG_LINUX_5_10
- KERNEL_LOADADDR := 0x80400000
-else
- KERNEL_LOADADDR := 0x80100000
-endif
+KERNEL_LOADADDR := 0x80100000
define Device/Default
PROFILES := Default
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index e0c3b4174f..f6a7c6c440 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,amazon-ena))
define KernelPackage/amd-xgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AMD Ethernet on SoC support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +(LINUX_5_10||LINUX_5_15):kmod-mdio-devres
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +kmod-mdio-devres
KCONFIG:=CONFIG_AMD_XGBE
FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/xgbe/amd-xgbe.ko
AUTOLOAD:=$(call AutoLoad,35,amd-xgbe)