summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-05-16 10:48:28 +0200
committerPetr Štetiar <ynezz@true.cz>2023-05-16 14:31:14 +0200
commit6b17e19ad8560151f399afb7b10ea44315865f69 (patch)
treefa46454c09c88bbaa978d7e1376b32181ddd4e2c
parentd26ecbcf95e2c2ecf5380fdee733c6b46276e265 (diff)
downloadopenwrt-6b17e19ad8560151f399afb7b10ea44315865f69.tar.gz
libbsd: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so just having _GNU_SOURCE defined is not enough anymore. _LARGEFILE64_SOURCE has to be defined in the source, or CFLAGS can be used to pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions. Fixes: fff878c5bcda ("toolchain/musl: update to 1.2.4") Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/libs/libbsd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libs/libbsd/Makefile b/package/libs/libbsd/Makefile
index 92c7054e3b..1872e3ce30 100644
--- a/package/libs/libbsd/Makefile
+++ b/package/libs/libbsd/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libbsd
PKG_VERSION:=0.11.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://libbsd.freedesktop.org/releases
@@ -29,6 +29,8 @@ define Package/libbsd/description
This library provides useful functions commonly found on BSD systems, and lacking on others like GNU systems, thus making it easier to port projects with strong BSD origins, without needing to embed the same code over and over again on each project.
endef
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig