summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 10:13:43 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:06:14 +0200
commitd440ebb2a80b8ac98d7f5d6025b7946ab824b084 (patch)
treea498a9651892f17724c292add3a76c9ae957874d
parent1fda304d8e950d40cd741befa2db6f8ecba80e1c (diff)
downloadopenwrt-d440ebb2a80b8ac98d7f5d6025b7946ab824b084.tar.gz
build: remove backwards compatibility for PKG_USE_MIPS16
All package feeds have been refactored to PKG_BUILD_FLAGS:=no-mips16. Signed-off-by: Andre Heider <a.heider@gmail.com>
-rw-r--r--include/package.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/include/package.mk b/include/package.mk
index d80f3bce49..f03cb15f05 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -24,12 +24,6 @@ PKG_JOBS?=$(if $(PKG_BUILD_PARALLEL),$(MAKE_J),-j1)
endif
PKG_BUILD_FLAGS?=
-# TODO remove this when all packages moved to PKG_BUILD_FLAGS=no-mips16
-PKG_USE_MIPS16?=1
-ifneq ($(strip $(PKG_USE_MIPS16)),1)
- PKG_BUILD_FLAGS+=no-mips16
-endif
-
__unknown_flags=$(filter-out no-iremap no-mips16 gc-sections no-gc-sections lto no-lto,$(PKG_BUILD_FLAGS))
ifneq ($(__unknown_flags),)
$(error unknown PKG_BUILD_FLAGS: $(__unknown_flags))