summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /package/kernel/linux/modules/fs.mk
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadopenwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 547cc79644..77d8d6c98b 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -98,20 +98,18 @@ define KernelPackage/fs-cifs
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +LINUX_5_10:kmod-crypto-md4\
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \
+kmod-crypto-cmac \
+kmod-crypto-hmac \
- +LINUX_5_10:kmod-crypto-arc4 \
+kmod-crypto-aead \
+kmod-crypto-ccm \
+kmod-crypto-ecb \
+kmod-crypto-des \
- +(LINUX_5_15):kmod-asn1-decoder \
- +(LINUX_5_15):kmod-oid-registry \
- +(LINUX_5_15):kmod-dnsresolver
+ +kmod-asn1-decoder \
+ +kmod-oid-registry \
+ +kmod-dnsresolver
endef
define KernelPackage/fs-cifs/description
@@ -367,7 +365,6 @@ $(eval $(call KernelPackage,fs-msdos))
define KernelPackage/fs-netfs
SUBMENU:=$(FS_MENU)
TITLE:=Network Filesystems support
- DEPENDS:=@LINUX_5_15
KCONFIG:= CONFIG_NETFS_SUPPORT
FILES:=$(LINUX_DIR)/fs/netfs/netfs.ko
AUTOLOAD:=$(call AutoLoad,28,netfs)
@@ -531,7 +528,6 @@ define KernelPackage/fs-ntfs3
KCONFIG:= CONFIG_NTFS3_FS CONFIG_NTFS3_FS_POSIX_ACL=y
FILES:=$(LINUX_DIR)/fs/ntfs3/ntfs3.ko
$(call AddDepends/nls)
- DEPENDS+=@!LINUX_5_10
AUTOLOAD:=$(call AutoLoad,80,ntfs3)
endef