summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /package/kernel/linux/modules/input.mk
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadopenwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk17
1 files changed, 1 insertions, 16 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 6cc72207f3..92587b1874 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -92,7 +92,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
define KernelPackage/input-gpio-keys-polled
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Polled GPIO key support
- DEPENDS:=@GPIO_SUPPORT +kmod-input-core +LINUX_5_10:kmod-input-polldev
+ DEPENDS:=@GPIO_SUPPORT +kmod-input-core
KCONFIG:= \
CONFIG_KEYBOARD_GPIO_POLLED \
CONFIG_INPUT_KEYBOARD=y
@@ -142,21 +142,6 @@ endef
$(eval $(call KernelPackage,input-joydev))
-define KernelPackage/input-polldev
- SUBMENU:=$(INPUT_MODULES_MENU)
- TITLE:=Polled Input device support
- DEPENDS:=+kmod-input-core @LINUX_5_10
- KCONFIG:=CONFIG_INPUT_POLLDEV
- FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-endef
-
-define KernelPackage/input-polldev/description
- Kernel module for support of polled input devices
-endef
-
-$(eval $(call KernelPackage,input-polldev))
-
-
define KernelPackage/input-matrixkmap
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Input matrix devices support