summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-01-30 10:55:53 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-19 19:44:39 +0100
commit81fd360a6331ccaaf85440f9d5e1c9ed66e25f6b (patch)
tree6c4b7cfa95af4809683b74e56d2e30d4d8bb9f4d /toolchain
parenteb093c517421465d8636fab5eb4fb890d0858a47 (diff)
downloadopenwrt-81fd360a6331ccaaf85440f9d5e1c9ed66e25f6b.tar.gz
toolchain/glibc: fixup the libm.so linker script too
Add it to the existing list to fix it up. Found by mold: toolchain-x86_64_gcc-12.2.0_glibc/lib/libm.so:4: GROUP ( /lib/libm.so.6 AS_NEEDED ( /lib/libmvec.so.1 ) ) ^ library not found: /lib/libm.so.6 Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index 24526ceec2..bfb5598274 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -20,7 +20,7 @@ define Host/Install
install
( cd $(TOOLCHAIN_DIR) ; \
for d in lib usr/lib ; do \
- for f in libc.so libpthread.so libgcc_s.so ; do \
+ for f in libc.so libm.so libpthread.so libgcc_s.so ; do \
if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
$(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
fi \