summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-11-14 13:47:18 +0100
committerJohn Crispin <blogic@openwrt.org>2013-11-15 17:10:20 +0100
commitf8d43c5f222b99d5a7a0e2bd1fdc0d442e030e89 (patch)
tree85239c8c62e0267c9472c4d1ebd82c02f17d8009 /CMakeLists.txt
parent0ff5e8917bc3205d9887d5f714369a0072829edc (diff)
downloadubox-f8d43c5f222b99d5a7a0e2bd1fdc0d442e030e89.tar.gz
add log daemon
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cfbbc8..1aa9a86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,3 +70,15 @@ TARGET_LINK_LIBRARIES(validate_data ${LIBS} validate)
INSTALL(TARGETS validate_data
RUNTIME DESTINATION sbin
)
+
+ADD_EXECUTABLE(logd log/logd.c log/syslog.c)
+TARGET_LINK_LIBRARIES(logd ${LIBS})
+INSTALL(TARGETS logd
+ RUNTIME DESTINATION sbin
+)
+
+ADD_EXECUTABLE(logread log/logread.c)
+TARGET_LINK_LIBRARIES(logread ${LIBS})
+INSTALL(TARGETS logread
+ RUNTIME DESTINATION sbin
+)