summaryrefslogtreecommitdiff
path: root/lua
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2014-04-06 21:41:32 +0200
committerFelix Fietkau <nbd@openwrt.org>2014-04-06 22:48:44 +0200
commited938cc8e423d4a33b8f31e6e6d1eb0805ae3d10 (patch)
treed9b78a8827fb3d26c7fcbbad46c5f289005da0bb /lua
parent31d4b691d96af442e8dfcefbb7acf85a448bba5c (diff)
downloaduci-ed938cc8e423d4a33b8f31e6e6d1eb0805ae3d10.tar.gz
uci: fix Lua finding
If ${LUAPATH} is not quoted and Lua is not provided, then following error occurs: "NOT" "No such file or directory" "EQUAL" "0" "OR" "EQUAL" "" Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Diffstat (limited to 'lua')
-rw-r--r--lua/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lua/CMakeLists.txt b/lua/CMakeLists.txt
index e4295d7..4ba8e37 100644
--- a/lua/CMakeLists.txt
+++ b/lua/CMakeLists.txt
@@ -36,7 +36,7 @@ IF(NOT LUAPATH)
)
IF(BUILD_LUA)
- IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR ${LUAPATH} EQUAL "")
+ IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR "${LUAPATH}" EQUAL "")
MESSAGE(SEND_ERROR "Lua was not found on your system")
ENDIF()
ENDIF()