summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-07-01 16:04:51 -0700
committerJohn Crispin <john@phrozen.org>2016-07-01 15:18:15 +0200
commitec80adaa1b47f28d426fa19c692011ce60b992d6 (patch)
treef5ddd7eeef16418021f7ceb1fd2395da26006079
parent17085b7abc0cd09c64ccace6f8d16ddee5729678 (diff)
downloadustream-ssl-ec80adaa1b47f28d426fa19c692011ce60b992d6.tar.gz
cmake: Find libubox/ustream.h header file
Add a CMake FIND_PATH and INCLUDE_DIRECTORIES searching for libubox/ustream-ssl.h. Some external toolchains which do not include standard locations would fail to find the header otherwise. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ce9bf8..49e79a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,9 @@ ELSE()
SET(SSL_LIB crypto ssl)
ENDIF()
+FIND_PATH(ubox_include_dir libubox/ustream.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
+
ADD_LIBRARY(ustream-ssl SHARED ustream-ssl.c ${SSL_SRC})
TARGET_LINK_LIBRARIES(ustream-ssl ubox ${SSL_LIB})