summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Eisenmann <4240-p3732@users.noreply.gitlab.freedesktop.org>2022-09-07 14:24:43 +0000
committerJan Rybar <jrybar@redhat.com>2022-09-07 14:24:43 +0000
commita405b3e00ac24ae21ea36834cfc61cbae041bf39 (patch)
tree3679c33ed7cc9cf6d05f61e84afa22b6135871cb /meson.build
parent91597f08929ddf1bc3a90a7122f9e23ea96d6e11 (diff)
downloadpolkit-a405b3e00ac24ae21ea36834cfc61cbae041bf39.tar.gz
build: add option to skip building polkitd
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8bab9ce..aeb0002 100644
--- a/meson.build
+++ b/meson.build
@@ -137,6 +137,11 @@ assert(cc.has_function('XML_ParserCreate', dependencies: expat_dep), 'Can\'t fin
duktape_req_version = '>= 2.2.0'
js_engine = get_option('js_engine')
+libs_only = get_option('libs-only')
+if libs_only
+ js_engine = ''
+endif
+
if js_engine == 'duktape'
js_dep = dependency('duktape', version: duktape_req_version, required: false)
if not js_dep.found()
@@ -387,6 +392,9 @@ endif
output += ' polkitd user: ' + polkitd_user + ' \n'
output += ' Javascript engine: ' + js_engine + '\n'
output += ' PAM support: ' + enable_pam.to_string() + '\n\n'
+if libs_only
+ output += ' !!! Only building polkit libraries, not polkitd !!!\n\n'
+endif
if enable_pam
output += ' PAM file auth: ' + pam_conf['PAM_FILE_INCLUDE_AUTH'] + '\n'
output += ' PAM file acount: ' + pam_conf['PAM_FILE_INCLUDE_ACCOUNT'] + '\n'