summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2021-07-22 16:55:08 -0700
committerEivind Næss <eivnaes@yahoo.com>2021-07-22 17:14:36 -0700
commit213078f7b6e663cde09cb8e2e428870edff6fffc (patch)
tree1982d0d083e32dd972a379bd632eb9921c9700b5 /Makefile.am
parent4e5baab4f7138f83b219ce6fceed16e415853082 (diff)
downloadppp-213078f7b6e663cde09cb8e2e428870edff6fffc.tar.gz
Fixing up install targets for man pages and file permissions of secrets files
Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 275bca1..15b2d09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,8 +22,11 @@ install-am:
(cd solaris ; $(MAKE) -f Makefile install)
endif
-sampledir = $(sysconfdir)/$(PACKAGE)
+install-data-hook:
+ (cd $(DESTDIR)/$(sysconfdir)/$(PACKAGE) ; \
+ chmod 600 chap-secrets pap-secrets eaptls-server eaptls-client)
+sampledir = $(sysconfdir)/$(PACKAGE)
sample_DATA = \
etc.ppp/options \
etc.ppp/chap-secrets \