summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 275bca1..15b2d09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,8 +22,11 @@ install-am:
(cd solaris ; $(MAKE) -f Makefile install)
endif
-sampledir = $(sysconfdir)/$(PACKAGE)
+install-data-hook:
+ (cd $(DESTDIR)/$(sysconfdir)/$(PACKAGE) ; \
+ chmod 600 chap-secrets pap-secrets eaptls-server eaptls-client)
+sampledir = $(sysconfdir)/$(PACKAGE)
sample_DATA = \
etc.ppp/options \
etc.ppp/chap-secrets \