summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-07-05 14:52:26 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-07-05 14:52:26 +0000
commit0c54799197712812735ab19401379023792b8829 (patch)
treee419a819957a975c03321d0a322009ca9669e1b1 /gtk/Makefile.am
parent158516210b4e9a8704dc4abdf859e500b6470b97 (diff)
downloadpygtk-0c54799197712812735ab19401379023792b8829.tar.gz
Add infrastructure to handle lazy loading. Move keysyms to be loaded
* gtk/Makefile.am: * gtk/__init__.py: * gtk/_lazyutils.py: * tests/Makefile.am: * tests/test_api.py: Add infrastructure to handle lazy loading. Move keysyms to be loaded lazily. Add API tests to make sure keysyms works.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 7f233c06..64f31d73 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -20,10 +20,11 @@ pygtkexec_LTLIBRARIES =
# gtk python scripts
pygtkdir = $(pkgpythondir)/gtk
-pygtk_PYTHON = \
- __init__.py \
- compat.py \
- deprecation.py \
+pygtk_PYTHON = \
+ __init__.py \
+ _lazyutils.py \
+ compat.py \
+ deprecation.py \
keysyms.py
# gtk headers