summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@divmod.com>2008-12-31 16:15:30 -0500
committerJean-Paul Calderone <exarkun@divmod.com>2008-12-31 16:15:30 -0500
commit3329c3045f7e807ac8ea4673b1031851bd7138c8 (patch)
treef0586e7d63c047fbb8df2492e7db1b69cc5a0b68 /setup.py
parenta4be22af9b16022cb58c2cdb97c0e06ff40f07d2 (diff)
parentf8c5fabe13692d533b349d501eea7a13efbf81a5 (diff)
downloadpyopenssl-3329c3045f7e807ac8ea4673b1031851bd7138c8.tar.gz
update to trunk tip
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c5c0247..c12b876 100755
--- a/setup.py
+++ b/setup.py
@@ -102,7 +102,13 @@ LibraryDirs = None
# Add more platforms here when needed
if os.name == 'nt' or sys.platform == 'win32':
Libraries = ['eay32', 'Ws2_32']
- ExtraObjects = [r"c:\Python25\libs\ssleay32.a"]
+ # Try to find it...
+ for path in ["c:/Python25/libs/", "C:/Python26/libs/", "C:/OpenSSL/lib/MinGW/"]:
+ if os.path.exists(os.path.join(path, "ssleay32.a")):
+ ExtraObjects = [os.path.join(path, "ssleay32.a")]
+ break
+ else:
+ raise SystemExit("Cannot find ssleay32.a, aborting")
else:
Libraries = ['ssl', 'crypto']
ExtraObjects = []