summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c5c0247..c12b876 100755
--- a/setup.py
+++ b/setup.py
@@ -102,7 +102,13 @@ LibraryDirs = None
# Add more platforms here when needed
if os.name == 'nt' or sys.platform == 'win32':
Libraries = ['eay32', 'Ws2_32']
- ExtraObjects = [r"c:\Python25\libs\ssleay32.a"]
+ # Try to find it...
+ for path in ["c:/Python25/libs/", "C:/Python26/libs/", "C:/OpenSSL/lib/MinGW/"]:
+ if os.path.exists(os.path.join(path, "ssleay32.a")):
+ ExtraObjects = [os.path.join(path, "ssleay32.a")]
+ break
+ else:
+ raise SystemExit("Cannot find ssleay32.a, aborting")
else:
Libraries = ['ssl', 'crypto']
ExtraObjects = []