summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@divmod.com>2009-02-13 15:24:22 -0500
committerJean-Paul Calderone <exarkun@divmod.com>2009-02-13 15:24:22 -0500
commitfa85e199da46a2c0ef9d0f6053eddd04ac664bb9 (patch)
treebc779a686cf8387f4f1cfb78f4dcd0bc582c6540 /setup.py
parent86d7f938db719152f2e97483899db03a929737cb (diff)
downloadpyopenssl-fa85e199da46a2c0ef9d0f6053eddd04ac664bb9.tar.gz
Experimental change to remove the "ExtraObjects" stuff. Hypothesis: ExtraObjects is superfluous to the build and removing it will have no negative consequences.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 4 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 78c281f..9fa5f8a 100755
--- a/setup.py
+++ b/setup.py
@@ -43,26 +43,17 @@ LibraryDirs = None
# Add more platforms here when needed
if os.name == 'nt' or sys.platform == 'win32':
Libraries = ['eay32', 'Ws2_32']
- # Try to find it...
- for path in ["C:\\Python25\\libs\\", "C:\\Python26\\libs\\", "C:\\OpenSSL\\lib\\MinGW\\"]:
- ssleay32 = os.path.join(path, "ssleay32.a")
- if os.path.exists(ssleay32):
- ExtraObjects = [ssleay32]
- break
- else:
- raise SystemExit("Cannot find ssleay32.a, aborting")
else:
Libraries = ['ssl', 'crypto']
- ExtraObjects = []
if sys.platform == 'darwin':
IncludeDirs = ['/sw/include']
LibraryDirs = ['/sw/lib']
# On Windows, make sure the necessary .dll's get added to the egg.
-data_files = []
-if sys.platform == 'win32':
- data_files = [("OpenSSL", ExtraObjects)]
+# data_files = []
+# if sys.platform == 'win32':
+# data_files = [("OpenSSL", ExtraObjects)]
def mkExtension(name):
@@ -70,8 +61,7 @@ def mkExtension(name):
src = globals()[name.lower() + '_src']
dep = globals()[name.lower() + '_dep']
return Extension(modname, src, libraries=Libraries, depends=dep,
- include_dirs=IncludeDirs, library_dirs=LibraryDirs,
- extra_objects=ExtraObjects)
+ include_dirs=IncludeDirs, library_dirs=LibraryDirs)
setup(name='pyOpenSSL', version=__version__,
package_dir = {'OpenSSL': '.'},