summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2021-08-26 18:25:29 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2021-08-26 18:25:29 -0400
commit1f0a33b2ff3507b257cbe8c8f5eefbde988f7e30 (patch)
tree2780597651a8a1c9de6618578d66a896e9437d6f /tools
parentb421b5b9e3098e41ac7abab3346b6a64d4a51b4f (diff)
downloadalembic-1f0a33b2ff3507b257cbe8c8f5eefbde988f7e30.tar.gz
decouple pyproject.toml from the test suite
tools/write_pyi.py is run as part of the test suite, which has to run from a source distribution, which does not have pyproject.toml right now due to issues reported w/ pip. these pip issues are probably resolved now however we have not gone back to including pyproject.toml at the moment. so we therefore have to hardcode the single "-l79" black config option in write_pyi.py. Change-Id: I877f69eb2322f6cbb39ed4c6d4a9adf598703223
Diffstat (limited to 'tools')
-rw-r--r--tools/write_pyi.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/write_pyi.py b/tools/write_pyi.py
index 2d9efd5..054d27f 100644
--- a/tools/write_pyi.py
+++ b/tools/write_pyi.py
@@ -77,10 +77,12 @@ def generate_pyi_for_proxy(
{"entrypoint": "zimports", "options": "-e"},
ignore_output=ignore_output,
)
- pyproject = Path(__file__).parent.parent / "pyproject.toml"
+ # note that we do not distribute pyproject.toml with the distribution
+ # right now due to user complaints, so we can't refer to it here because
+ # this all has to run as part of the test suite
console_scripts(
str(destination_path),
- {"entrypoint": "black", "options": f"--config {pyproject}"},
+ {"entrypoint": "black", "options": "-l79"},
ignore_output=ignore_output,
)