summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/write_pyi.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/write_pyi.py b/tools/write_pyi.py
index 2d9efd5..054d27f 100644
--- a/tools/write_pyi.py
+++ b/tools/write_pyi.py
@@ -77,10 +77,12 @@ def generate_pyi_for_proxy(
{"entrypoint": "zimports", "options": "-e"},
ignore_output=ignore_output,
)
- pyproject = Path(__file__).parent.parent / "pyproject.toml"
+ # note that we do not distribute pyproject.toml with the distribution
+ # right now due to user complaints, so we can't refer to it here because
+ # this all has to run as part of the test suite
console_scripts(
str(destination_path),
- {"entrypoint": "black", "options": f"--config {pyproject}"},
+ {"entrypoint": "black", "options": "-l79"},
ignore_output=ignore_output,
)